blob: 5c24c77d7700479bea418aacddaa752f6dd1c6f8 [file] [log] [blame]
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=4
inherit multilib
DESCRIPTION="Charset conversion library for TI calculators"
HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
SRC_URI="mirror://sourceforge/tilp/tilp2-linux/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
IUSE="doc iconv static-libs"
RDEPEND="dev-libs/glib:2"
DEPEND="${RDEPEND}
virtual/pkgconfig"
DOCS=( AUTHORS LOGO NEWS README ChangeLog docs/api.txt )
src_configure() {
econf \
$(use_enable static-libs static) \
$(use_enable iconv)
}
src_install() {
default
if use doc; then
dohtml docs/html/*
docinto charsets
dohtml docs/charsets/*
fi
use static-libs || rm -f "${D}"/usr/$(get_libdir)/${PN}.la
}