blob: b06f628fa020a404b6c25c2d4b627f204e8d5bcf [file] [log] [blame]
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=4
inherit autotools eutils multilib
DESCRIPTION="A library and API for manipulating large SNP datasets"
HOMEPAGE="http://www.birc.au.dk/~mailund/SNPFile/"
SRC_URI="http://www.birc.au.dk/~mailund/SNPFile/download/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
IUSE="static-libs"
KEYWORDS="amd64 x86"
DEPEND="dev-libs/boost"
RDEPEND="${DEPEND}"
src_prepare() {
epatch \
"${FILESDIR}"/${P}-gcc44.patch \
"${FILESDIR}"/${P}-gentoo.diff \
"${FILESDIR}"/${P}-gold.patch
eautoreconf
}
src_configure() {
econf $(use_enable static-libs static)
}
src_install() {
default
use static-libs || rm "${D}"/usr/$(get_libdir)/lib${PN}.la
}