blob: e85fe95e11537b4ab6be57f5daaf8ad3fd8654a8 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit cmake-utils
if [[ ${PV} = *9999 ]]; then
inherit git-2
EGIT_REPO_URI="git://github.com/vitalif/${PN}2.git"
else
inherit vcs-snapshot
COMMIT="44cb91f94e67bcdad77ca564b4d8083cedf72251"
SRC_URI="https://github.com/vitalif/${PN}2/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
fi
DESCRIPTION="An open source Linux client for Google Drive"
HOMEPAGE="https://github.com/vitalif/grive2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="
dev-libs/boost:=
dev-libs/expat
>=dev-libs/json-c-0.11-r1:=
dev-libs/libgcrypt:0=
net-misc/curl
sys-libs/binutils-libs:0=
sys-libs/glibc
dev-libs/yajl
"
DEPEND="${RDEPEND}"