blob: 15e8d22b07207087c9cb895ca36839cdbb06cb26 [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
GST_ORG_MODULE="gst-plugins-ugly"
inherit eutils gstreamer
DESCRIPTION="Basepack of plugins for gstreamer"
HOMEPAGE="http://gstreamer.freedesktop.org/"
LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
IUSE="+orc"
RDEPEND="
>=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
>=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
>=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
"
DEPEND="${RDEPEND}
>=dev-util/gtk-doc-am-1.12
"
multilib_src_configure() {
gstreamer_multilib_src_configure
if multilib_is_native_abi; then
ln -s "${S}"/docs/plugins/html docs/plugins/html || die
fi
}
multilib_src_install_all() {
DOCS="AUTHORS ChangeLog NEWS README RELEASE"
einstalldocs
prune_libtool_files --modules
}