blob: 3cf7d28f8c56be0750dd4c0c98d7d80831322c18 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit toolchain-funcs eutils
DESCRIPTION="Converts images from gif format to png format"
HOMEPAGE="http://catb.org/~esr/gif2png/"
SRC_URI="http://catb.org/~esr/${PN}/${P}.tar.gz"
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
RDEPEND=">=media-libs/libpng-1.2:0
sys-libs/zlib"
DEPEND="${RDEPEND}"
src_prepare() {
epatch "${FILESDIR}"/${P}-makefile.patch
tc-export CC
}
src_install() {
emake DESTDIR="${D}" prefix="${EPREFIX}/usr" install
}