blob: 5162afa1fe19406028e041cf2c141637aedd2d53 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
KDE_REQUIRED="never"
inherit mono-env kde4-base
DESCRIPTION="C# bindings for Qt"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="debug +phonon qscintilla webkit"
HOMEPAGE="https://techbase.kde.org/Development/Languages/Qyoto"
DEPEND="
dev-lang/mono
$(add_kdebase_dep smokeqt 'opengl,phonon?,qscintilla?,webkit?')
"
RDEPEND="${DEPEND}"
pkg_setup() {
mono-env_pkg_setup
kde4-base_pkg_setup
}
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_with phonon)
$(cmake-utils_use_disable qscintilla QScintilla)
$(cmake-utils_use_disable webkit QtWebKit)
)
kde4-base_src_configure
}