blob: 79bef2f17aef672072187b08fa816943591d8828 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit toolchain-funcs games
DESCRIPTION="Console Minesweeper"
HOMEPAGE="http://freshmeat.net/projects/freesweep"
SRC_URI="http://www.upl.cs.wisc.edu/~hartmann/sweep/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86 ~ppc-macos"
RDEPEND="sys-libs/ncurses:0"
DEPEND="${RDEPEND}
virtual/pkgconfig"
src_compile() {
emake LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses)"
}
src_install() {
dogamesbin freesweep
dodoc README
doman freesweep.6
prepgamesdirs
}