blob: 838ff17050d2309455a8e825de00d0b31868a4fe [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
USE_RUBY="ruby19 ruby20 ruby21 ruby22"
RUBY_FAKEGEM_TASK_DOC="docs"
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="considerations.txt History.txt README.txt"
inherit ruby-fakegem
DESCRIPTION="Pragmatic application deployment automation, without mercy"
HOMEPAGE="http://rubyhitsquad.com/Vlad_the_Deployer.html"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
ruby_add_bdepend ">=dev-ruby/hoe-2.9.2
test? ( dev-ruby/minitest )"
ruby_add_rdepend ">=dev-ruby/rake-remote_task-2.1"
all_ruby_prepare() {
# Keep Isolate from managing the dependencies.
sed -i -e '/isolate/ s:^:#:' -e '/rubyforge/ s:^:#:' Rakefile || die
}