blob: 8c5857d6336430b67d4fb6b0cf68b6213978dd20 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
USE_RUBY="ruby19 ruby20 ruby21 ruby22"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="FAQ.txt History.txt README.md"
inherit ruby-fakegem
DESCRIPTION="Trollop is a commandline option parser for Ruby"
HOMEPAGE="http://manageiq.github.io/trollop/"
LICENSE="MIT"
KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
SLOT="2"
IUSE=""
ruby_add_bdepend "test? ( dev-ruby/chronic )"
each_ruby_test() {
MUTANT=true ${RUBY} -Ilib:test test/test_trollop.rb || die "Tests failed."
}