blob: 3919c2414f2a54f0efb59a1940d70e0e5a951367 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
# Ruby 1.9 fails tests
USE_RUBY="ruby20 ruby21 ruby22"
RUBY_FAKEGEM_RECIPE_TEST="none"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README.md"
RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
inherit ruby-fakegem
DESCRIPTION="All the stuff that isn't good enough for a real library"
HOMEPAGE="https://github.com/flori/tins"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
each_ruby_test() {
ruby-ng_testrb-2 -Ilib tests/*_test.rb
}