blob: fa4ea51a85487d0ab5926264d1762948ce9c4e64 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
USE_RUBY="ruby19 ruby20 ruby21 ruby22"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
inherit ruby-fakegem
DESCRIPTION="A simple option parser with an easy to remember syntax and friendly API"
HOMEPAGE="https://github.com/injekt/slop"
SRC_URI="https://github.com/injekt/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
LICENSE="MIT"
SLOT="3"
KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
IUSE=""
ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
all_ruby_prepare() {
sed -i -e '/git ls-files/d' slop.gemspec || die
}