blob: 2d55950ad3de4e3c49c4f67ed0bc908f83175aa1 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
USE_RUBY="ruby19 ruby20"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="README.md"
RUBY_FAKEGEM_EXTRAINSTALL="rails init.rb VERSION VERSION_NAME"
# Don't install binaries for compatibility with higher slot.
RUBY_FAKEGEM_BINWRAP=""
inherit ruby-fakegem
DESCRIPTION="An extension of CSS3, adding nested rules, variables, mixins, selector inheritance, and more"
HOMEPAGE="http://sass-lang.com/"
LICENSE="MIT"
KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
SLOT="0"
IUSE=""
ruby_add_bdepend "doc? ( >=dev-ruby/yard-0.5.3 )"
ruby_add_rdepend ">=dev-ruby/listen-0.7.2:0 !!<dev-ruby/haml-3.1"
# tests could use `less` if we had it
all_ruby_prepare() {
rm -rf vendor/listen || die
# Don't require maruku as markdown provider but let yard decide.
sed -i -e '/maruku/d' .yardopts || die
}