blob: 53c849a423b8ce88550f13cb305fb31931cb1c9b [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
USE_RUBY="ruby19 ruby20 ruby21 ruby22"
inherit virtualx ruby-ng-gnome2
DESCRIPTION="Ruby GDK-3.x bindings"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
DEPEND+=" x11-libs/gtk+:3"
RDEPEND+=" x11-libs/gtk+:3"
ruby_add_bdepend ">=dev-ruby/ruby-glib2-${PV}"
ruby_add_rdepend ">=dev-ruby/ruby-gdkpixbuf2-${PV}
>=dev-ruby/ruby-atk-${PV}
>=dev-ruby/ruby-cairo-gobject-${PV}
>=dev-ruby/ruby-pango-${PV}"
all_ruby_prepare() {
# Avoid unneeded dependency on test-unit-notify.
sed -i -e '/notify/ s:^:#:' \
test/gdk-test-utils.rb || die
# Avoid compilation of dependencies during test.
sed -i -e '/system/,/^ end/ s:^:#:' test/run-test.rb || die
}
each_ruby_configure() {
:
}
each_ruby_compile() {
:
}
each_ruby_test() {
VIRTUALX_COMMAND="${RUBY} test/run-test.rb"
virtualmake || die
}
each_ruby_install() {
each_fakegem_install
}