blob: 009e7fed7fe66ceb0a189cd0d2099de3c8561380 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
USE_RUBY="ruby19 ruby20 ruby21 ruby22"
RUBY_FAKEGEM_RECIPE_TEST="rspec"
RUBY_FAKEGEM_RECIPE_DOC="none"
RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
inherit ruby-fakegem
DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
HOMEPAGE="http://rspec.rubyforge.org/"
SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
LICENSE="MIT"
SLOT="2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
ruby_add_bdepend "
test? (
>=dev-ruby/rspec-core-2.10.0:2
>=dev-ruby/rspec-expectations-2.99.0:2
)"
all_ruby_prepare() {
# Don't set up bundler: it doesn't understand our setup.
sed -i -e '/[Bb]undler/d' Rakefile || die
# Remove the Gemfile to avoid running through 'bundle exec'
rm Gemfile || die
# Remove .rspec options to avoid dependency on newer rspec when
# bootstrapping.
rm .rspec || die
# Avoid a weird, and failing, test testing already installed code.
sed -e '/has an up-to-date caller_filter file/,/end/ s:^:#:' -i spec/rspec/mocks_spec.rb || die
}
each_ruby_prepare() {
case ${RUBY} in
*ruby22)
# Psych and Syck are not supported by default anymore on ruby22.
rm spec/rspec/mocks/serialization_spec.rb || die
;;
esac
}