blob: a3394d71bce1d5b156875c43ebbeb32b595f2dc9 [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
USE_RUBY="ruby20 ruby21 ruby22"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="README.md"
inherit ruby-fakegem
DESCRIPTION="Deprecated sanitizer API extracted from Action View"
HOMEPAGE="https://github.com/rails/rails-deprecated_sanitizer"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
IUSE=""
ruby_add_rdepend ">=dev-ruby/activesupport-4.2"
ruby_add_bdepend "test? ( >=dev-ruby/actionview-4.2 )"
each_ruby_test() {
${RUBY} -Ilib:test:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
}