blob: 46ef01b7bf51b95528963e216944c0b8072c753e [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
# jruby: not compatible with its fork implementation
USE_RUBY="ruby19 ruby20 ruby21 ruby22"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README"
inherit ruby-fakegem
DESCRIPTION="Open3::popen3 with exit status"
HOMEPAGE="http://rubyforge.org/projects/codeforpeople/"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
IUSE=""
ruby_add_bdepend "test? ( dev-ruby/minitest )"
all_ruby_prepare() {
mv rakefile Rakefile || die
}
all_ruby_install() {
all_fakegem_install
insinto /usr/share/doc/${PF}/samples
doins samples/*
}
each_ruby_test() {
${RUBY} -Ilib -Itest/support test/*.rb || die
}