blob: a4b69d5d24dc6cb55dccf46ac1e9e0255df248a6 [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
USE_RUBY="ruby20 ruby21 ruby22"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_DOCDIR=""
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
inherit ruby-fakegem versionator
DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource"
HOMEPAGE="https://github.com/rails/rails"
SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
IUSE=""
RUBY_S="rails-${PV}/${PN}"
ruby_add_rdepend "
~dev-ruby/activesupport-${PV}:*
>=dev-ruby/builder-3.1:* =dev-ruby/builder-3*:*
"
ruby_add_bdepend "
test? (
>=dev-ruby/railties-4.2.0
dev-ruby/test-unit:2
>=dev-ruby/mocha-0.14.0:0.14
>=dev-ruby/bcrypt-ruby-3.1.7
)"
all_ruby_prepare() {
# Set test environment to our hand.
sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
}