blob: 7505c992a44f9290e0026290e94b0c31c7689a60 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
QT5_MODULE="qttools"
inherit qt5-build
DESCRIPTION="Tool for viewing on-line documentation in Qt help file format"
if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
fi
IUSE="webkit"
DEPEND="
~dev-qt/qtcore-${PV}
~dev-qt/qtgui-${PV}
~dev-qt/qthelp-${PV}
~dev-qt/qtnetwork-${PV}
~dev-qt/qtprintsupport-${PV}
~dev-qt/qtsql-${PV}[sqlite]
~dev-qt/qtwidgets-${PV}
webkit? ( ~dev-qt/qtwebkit-${PV} )
"
RDEPEND="${DEPEND}"
QT5_TARGET_SUBDIRS=(
src/assistant/assistant
)
src_prepare() {
qt_use_disable_mod webkit webkitwidgets \
src/assistant/assistant/assistant.pro
qt5-build_src_prepare
}