blob: 3746fd012b412408e83a4d1cf331510219f7f99e [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
#DISTUTILS_SRC_TEST="nosetests"
MY_PN="TurboCheetah"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="TurboGears plugin to support use of Cheetah templates"
HOMEPAGE="http://docs.turbogears.org/TurboCheetah https://pypi.python.org/pypi/TurboCheetah"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RDEPEND=">=dev-python/cheetah-2.0.1[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( ${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}] )"
S="${WORKDIR}/${MY_P}"
python_test() {
nosetests || die "test failed"
}