blob: a6ddf149469204aea1fb1d7206ffd14f14b659a7 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit eutils distutils-r1
DESCRIPTION="Set of facilities to extend Python with C++"
HOMEPAGE="http://cxx.sourceforge.net"
SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
IUSE="doc examples"
python_prepare_all() {
# Without this, pysvn fails.
# CXX/Python2/Config.hxx: No such file or directory
sed -e "/^#include/s:/Python[23]/:/:" -i CXX/*/*.hxx || die "sed failed"
# Remove python2 print statement
echo > Lib/__init__.py || die
local PATCHES=(
"${FILESDIR}/${PN}-6.2.3-installation.patch"
)
distutils-r1_python_prepare_all
}
python_install_all() {
use doc && local HTML_DOCS=( Doc/. )
use examples && local EXAMPLES=( Demo/Python{2,3}/. )
distutils-r1_python_install_all
}