blob: 87daee60d141558f9a51f43efd8a9e8738a0d6a4 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 pypy )
inherit distutils-r1
DESCRIPTION="Package of Hachoir parsers used to open binary files"
HOMEPAGE="https://bitbucket.org/haypo/hachoir/wiki/hachoir-parser https://pypi.python.org/pypi/hachoir-parser"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
RDEPEND=">=dev-python/hachoir-core-1.3[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
python_configure_all() {
mydistutilsargs=( --setuptools )
}