blob: 8af5a0436fb19e4a338aaaf86b7bc798e27726af [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
inherit distutils-r1
DESCRIPTION="Rendering as a binning process"
HOMEPAGE="
https://github.com/ContinuumIO/abstract_rendering
http://pypi.python.org/pypi/abstract_rendering
"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="uni_indiana"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="test"
RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
python_prepare_all() {
sed \
-e 's:"-O3",::g' \
-i setup.py || die
distutils-r1_python_prepare_all
}