blob: 3a9bc3778d1a94cc593a2f1a6b86dcb27903cfbc [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit cmake-utils
DESCRIPTION="Lua bindings to zlib"
HOMEPAGE="https://github.com/brimworks/lua-zlib"
SRC_URI="https://github.com/brimworks/${PN}/tarball/v${PV} -> ${P}.tgz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE=""
RDEPEND="dev-lang/lua:0
sys-libs/zlib"
DEPEND="${RDEPEND}
virtual/pkgconfig"
src_unpack() {
unpack ${A}
mv *-${PN}-* "${S}" || die
}
src_configure() {
local mycmakeargs="-DINSTALL_CMOD='$(pkg-config --variable INSTALL_CMOD lua)'"
cmake-utils_src_configure
}