blob: 048b660214b8ffe5cf5846dc9d3417ece461a6a8 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
NETSURF_BUILDSYSTEM=buildsystem-1.3
inherit flag-o-matic netsurf
DESCRIPTION="library for building efficient parsers, written in C"
HOMEPAGE="http://www.netsurf-browser.org/projects/libparserutils/"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~m68k-mint"
IUSE="iconv test"
DEPEND="test? ( dev-lang/perl )"
DOCS=( README docs/Todo )
PATCHES=( "${FILESDIR}"/${P}-glibc-2.20.patch )
src_configure() {
netsurf_src_configure
append-cflags "-D$(usex iconv WITH WITHOUT)_ICONV_FILTER"
}