blob: cdb7159c8676d258bdbb393c137c0e4a1484fe0d [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
# ebuild generated by hackport 0.3.6.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Lift computations from the bottom of a transformer stack"
HOMEPAGE="https://github.com/mvv/transformers-base"
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86 ~amd64-linux"
IUSE="+orphaninstances"
RDEPEND=">=dev-haskell/transformers-0.2:=[profile?]
>=dev-lang/ghc-6.10.4:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6.0.3
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag orphaninstances orphaninstances)
}