blob: 1c0bdca8615abadc5983dfa24cae16cd798443ad [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
# ebuild generated by hackport 0.4.3.9999
CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Conversion between formats used to represent mathematics"
HOMEPAGE="https://github.com/jgm/texmath"
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="executable"
RDEPEND="dev-haskell/mtl:=[profile?]
>=dev-haskell/pandoc-types-1.12.3.3:=[profile?]
>=dev-haskell/parsec-3:=[profile?]
dev-haskell/syb:=[profile?]
dev-haskell/xml:=[profile?]
>=dev-lang/ghc-7.4.1:=
executable? ( dev-haskell/aeson:=[profile?]
dev-haskell/network:=[profile?]
dev-haskell/split:=[profile?]
dev-haskell/text:=[profile?] )
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.10
test? ( dev-haskell/temporary
dev-haskell/utf8-string
!executable? ( dev-haskell/split
dev-haskell/text ) )
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag executable executable)
}