blob: b8acec2e0da6da31fe0dd708fbff972d67dce7c2 [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
# ebuild generated by hackport 0.4.6.9999
CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Parsing and extracting information from (possibly malformed) HTML/XML documents"
HOMEPAGE="https://github.com/ndmitchell/tagsoup#readme"
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="download testprog"
RDEPEND="dev-haskell/text:=[profile?]
>=dev-lang/ghc-7.4.1:=
download? ( dev-haskell/network:=[profile?] )
testprog? ( >=dev-haskell/quickcheck-2.4:2=[profile?] )
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag download download) \
$(cabal_flag testprog testprog)
}