blob: f86c446847b1993530575ab67a421282d3c6374f [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
# ebuild generated by hackport 0.4.4.9999
CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
inherit haskell-cabal
MY_PN="hS3"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Interface to Amazon's Simple Storage Service (S3)"
HOMEPAGE="http://gregheartsfield.com/hS3/"
SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="+network-uri"
RDEPEND=">=dev-haskell/crypto-4.1.0:=[profile?]
dev-haskell/dataenc:=[profile?]
>=dev-haskell/http-4000.0.0:=[profile?]
>=dev-haskell/hxt-9.0.0:=[profile?] <dev-haskell/hxt-10:=[profile?]
>=dev-haskell/missingh-0.18.6:=[profile?]
dev-haskell/random:=[profile?]
dev-haskell/regex-compat:=[profile?]
dev-haskell/utf8-string:=[profile?]
>=dev-lang/ghc-7.4.1:=
network-uri? ( >=dev-haskell/network-2.6:=[profile?]
>=dev-haskell/network-uri-2.6:=[profile?] )
!network-uri? ( <dev-haskell/network-2.6:=[profile?]
<dev-haskell/network-uri-2.6:=[profile?] )
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6
"
S="${WORKDIR}/${MY_P}"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag network-uri network-uri)
}