blob: a629230ef0714680e2dac055e7a12c73e3383356 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
# ebuild generated by hackport 0.4.5.9999
#hackport: flags: -usenativewindowslibraries
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
MY_PN="GLUT"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="A binding for the OpenGL Utility Toolkit"
HOMEPAGE="http://www.haskell.org/haskellwiki/Opengl"
SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND=">=dev-haskell/opengl-2.12:=[profile?] <dev-haskell/opengl-2.13:=[profile?]
>=dev-haskell/openglraw-2.3:=[profile?] <dev-haskell/openglraw-2.6:=[profile?]
>=dev-haskell/statevar-1.1:=[profile?] <dev-haskell/statevar-1.2:=[profile?]
>=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
>=dev-lang/ghc-7.4.1:=
media-libs/freeglut
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.10
"
S="${WORKDIR}/${MY_P}"
src_configure() {
haskell-cabal_src_configure \
--flag=-usenativewindowslibraries
}