blob: 9c46f8a473f107d5764a635b87672a07f12cb690 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
# ebuild generated by hackport 0.4.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Interface for versioning file stores"
HOMEPAGE="http://hackage.haskell.org/package/filestore"
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="+maxcount"
RDEPEND=">=dev-haskell/diff-0.2:=[profile?] <dev-haskell/diff-0.4:=[profile?]
>=dev-haskell/parsec-2:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
>=dev-haskell/split-0.1:=[profile?] <dev-haskell/split-0.3:=[profile?]
>=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-0.4:=[profile?]
>=dev-haskell/xml-1.3:=[profile?] <dev-haskell/xml-1.4:=[profile?]
>=dev-lang/ghc-7.4.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.10
test? ( >=dev-haskell/diff-0.2 <dev-haskell/diff-0.4
>=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.3
dev-haskell/mtl )
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag maxcount maxcount)
}