blob: 4c82761e6b2c1d53217967a614374be879e08cb5 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
# ebuild generated by hackport 0.4.2
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="DNS library in Haskell"
HOMEPAGE="http://hackage.haskell.org/package/dns"
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="dev-haskell/attoparsec:=[profile?]
dev-haskell/binary:=[profile?]
dev-haskell/blaze-builder:=[profile?]
>=dev-haskell/conduit-1.1:=[profile?]
>=dev-haskell/conduit-extra-1.1:=[profile?]
>=dev-haskell/iproute-1.2.4:=[profile?]
dev-haskell/mtl:=[profile?]
>=dev-haskell/network-2.3:=[profile?]
dev-haskell/random:=[profile?]
dev-haskell/resourcet:=[profile?]
>=dev-lang/ghc-7.4.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.10
test? ( dev-haskell/hspec )
"
# There are two additional test suites, "doctest" and "network" which
# both require network access.
src_test() {
haskell-cabal_src_test spec
}