blob: c4298fca3199a31072dae680d03e729be86f4492 [file] [log] [blame]
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
# ebuild generated by hackport 0.3.4
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Comonads"
HOMEPAGE="https://github.com/ekmett/comonad/"
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="+test-doctests"
RDEPEND=">=dev-haskell/contravariant-0.2.0.1:=[profile?] <dev-haskell/contravariant-1:=[profile?]
>=dev-haskell/distributive-0.2.2:=[profile?] <dev-haskell/distributive-1:=[profile?]
>=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.2:=[profile?]
>=dev-haskell/semigroups-0.8.3.1:=[profile?] <dev-haskell/semigroups-1:=[profile?]
>=dev-haskell/tagged-0.1:=[profile?] <dev-haskell/tagged-1:=[profile?]
>=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.4:=[profile?]
>=dev-lang/ghc-6.12.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.10
test? ( test-doctests? ( >=dev-haskell/doctest-0.9.1 ) )
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag test-doctests test-doctests)
}