blob: 8bfa8b61732b8ebd234972c0cb1f967581ca7380 [file] [log] [blame]
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=3
PYTHON_DEPEND="2:2.5"
inherit eutils python
DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
HOMEPAGE="https://github.com/ibus/ibus/wiki"
SRC_URI="https://ibus.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="nls"
RDEPEND=">=app-i18n/ibus-1.2.0.20100111
!>=app-i18n/ibus-1.4.99
app-i18n/anthy
>=dev-python/pygtk-2.15.2
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
dev-lang/swig
dev-util/intltool
virtual/pkgconfig
nls? ( >=sys-devel/gettext-0.16.1 )"
pkg_setup() {
python_set_active_version 2
python_pkg_setup
}
src_prepare() {
>py-compile #397497
}
src_configure() {
PYTHON="$(PYTHON -a)" econf $(use_enable nls)
}
src_install() {
emake DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog NEWS README || die
find "${ED}" -name '*.la' -type f -delete || die
}
pkg_postinst() {
elog
elog "app-dicts/kasumi is not required but probably useful for you."
elog
elog "# emerge app-dicts/kasumi"
elog
python_mod_optimize /usr/share/${PN}
}
pkg_postrm() {
python_mod_cleanup /usr/share/${PN}
}