blob: f9ecd55aacc16301ca53a0fb3bfdda7f753746b3 [file] [log] [blame]
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
inherit toolchain-funcs
MY_P="${PN}${PV//.}"
DESCRIPTION="LZMA Stream Compressor from the SDK"
HOMEPAGE="http://www.7-zip.org/sdk.html"
SRC_URI="mirror://sourceforge/sevenzip/${MY_P}.tar.bz2"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ia64 ~mips ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="doc"
S=${WORKDIR}
src_compile() {
cd CPP/7zip/Bundles/LzmaCon
emake -f makefile.gcc \
CXX="$(tc-getCXX) ${CXXFLAGS} ${CPPFLAGS}" \
CXX_C="$(tc-getCC) ${CFLAGS} ${CPPFLAGS}" \
|| die "Make failed"
}
src_install() {
newbin CPP/7zip/Bundles/LzmaCon/lzma lzmacon || die
dodoc lzma.txt history.txt
use doc && dodoc 7zC.txt 7zFormat.txt Methods.txt
}
pkg_postinst() {
einfo "The lzma binary is now 'lzmacon' to avoid xz-utils conflicts #218459"
}