blob: 615494594418e5024f6a5ef467a6d230b545ff8b [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
DESCRIPTION="System tray utility including support for KDE system tray icons"
HOMEPAGE="http://stalonetray.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug +graceful-exit kde"
RDEPEND="x11-libs/libX11
x11-libs/libICE
x11-libs/libSM
x11-libs/libXpm"
DEPEND="${RDEPEND}
x11-proto/xproto"
src_configure() {
econf $(use_enable debug) \
$(use_enable graceful-exit) \
$(use_enable kde native-kde)
}
src_install() {
emake DESTDIR="${D}" install
dodoc AUTHORS ChangeLog NEWS README stalonetrayrc.sample TODO
dohtml stalonetray.html
}