blob: 6f86670ec196b3e9399671745857851d7393db43 [file] [log] [blame]
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=4
DESCRIPTION="System tray utility including support for KDE system tray icons"
HOMEPAGE="http://stalonetray.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="debug +graceful-exit kde"
RDEPEND="x11-libs/libX11
x11-libs/libICE
x11-libs/libSM
x11-libs/libXpm"
DEPEND="${RDEPEND}
x11-proto/xproto"
src_configure() {
econf $(use_enable debug) \
$(use_enable graceful-exit) \
$(use_enable kde native-kde)
}
src_install() {
emake DESTDIR="${D}" install
dodoc AUTHORS ChangeLog NEWS README stalonetrayrc.sample TODO
dohtml stalonetray.html
}