blob: 7c91eff1afb74dac887fe2248578d5df3f5f89b4 [file] [log] [blame]
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="2"
inherit autotools eutils
DESCRIPTION="mouse tool for advanced features such as wheels and 3+ buttons"
HOMEPAGE="http://imwheel.sourceforge.net/"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~x86"
IUSE=""
RDEPEND="x11-libs/libXtst
x11-libs/libX11
x11-libs/libXmu
x11-libs/libXt
x11-libs/libXext"
DEPEND="${RDEPEND}
x11-proto/inputproto
x11-proto/xextproto
x11-proto/xproto
>=sys-apps/sed-4"
src_prepare() {
sed -i -e "s:/etc:${D}/etc:g" Makefile.am || die
eautoreconf
}
src_configure() {
local myconf
# don't build gpm stuff
myconf="--disable-gpm --disable-gpm-doc"
econf ${myconf} || die "configure failed"
}
src_install() {
emake DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS BUGS ChangeLog EMACS M-BA47 NEWS README TODO
}