blob: 05b5805d092c3d92f4c0e24963379c188eaee8c4 [file] [log] [blame]
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
inherit eutils toolchain-funcs
S="${WORKDIR}/${PN}${PV}"
DESCRIPTION="determine the color string in hex (or RGB components) by clicking on a pixel on the screen"
HOMEPAGE="http://www.muquit.com/muquit/software/grabc/grabc.html"
SRC_URI="http://www.muquit.com/muquit/software/${PN}/${PN}${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 x86"
IUSE=""
RDEPEND="x11-libs/libX11"
DEPEND="${RDEPEND}
x11-proto/xproto"
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-makefile.patch
}
src_compile() {
tc-export CC
emake || die "emake failed"
}
src_install() {
dobin grabc || die "dobin failed"
dodoc README || die "dodoc failed"
}