blob: df462c4a0bb35060ac83792021f50653195aae1e [file] [log] [blame]
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=4
inherit eutils autotools
DESCRIPTION="libsrs2 is the next generation Sender Rewriting Scheme library"
HOMEPAGE="http://www.libsrs2.org/"
SRC_URI="http://www.libsrs2.org/srs/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="static-libs"
DEPEND="!dev-perl/Mail-SRS"
RDEPEND="${DEPEND}"
src_prepare() {
epatch "${FILESDIR}/${P}-parallel-make.diff"
eautoreconf
}
src_configure() {
econf \
$(use_enable static-libs static)
}
src_install() {
default
use static-libs || find "${D}" -name '*.la' -delete
}