blob: 4b84eed43038763318e9565025c1ea15ffcd6407 [file] [log] [blame]
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="4"
inherit eutils flag-o-matic autotools
DESCRIPTION="An Portable Open Source UPnP Development Kit"
HOMEPAGE="http://pupnp.sourceforge.net/"
SRC_URI="mirror://sourceforge/pupnp/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux"
IUSE="debug doc ipv6 static-libs"
DOCS="NEWS README ChangeLog"
src_prepare() {
sed -e '/AX_CFLAGS_GCC_OPTION/s:-Os::g' \
-i "${S}/configure.ac" || die
# fix tests
chmod +x ixml/test/test_document.sh || die
eautoreconf
}
src_configure() {
use x86-fbsd && append-flags -O1
# w/o docdir to avoid sandbox violations
econf \
$(use_enable debug) \
$(use_enable ipv6) \
$(use_enable static-libs static) \
$(use_with doc documentation "${EPREFIX}/usr/share/doc/${PF}")
}
src_install () {
default
dobin upnp/sample/.libs/tv_{combo,ctrlpt,device}
use static-libs || find "${ED}" -type f -name '*.la' -delete
}
pkg_postinst() {
ewarn "Please remember to run revdep-rebuild when upgrading"
ewarn "from libupnp 1.4.x to libupnp 1.6.x , so packages"
ewarn "gets linked with the new library."
ewarn ""
ewarn "The revdep-rebuild script is part of the"
ewarn "app-portage/gentoolkit package."
}