blob: 6ecd4d8e29e3cbb0909fee321c7dd343ad8d85a9 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=4
inherit linux-info eutils
DESCRIPTION="the low-level library for netfilter related kernel/userspace communication"
HOMEPAGE="http://www.netfilter.org/projects/libnfnetlink/"
SRC_URI="http://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
IUSE="static-libs"
DOCS=( README )
pkg_setup() {
linux-info_pkg_setup
if kernel_is lt 2 6 18 ; then
ewarn "${PN} requires at least 2.6.18 kernel version"
fi
#netfilter core team has changed some option names with kernel 2.6.20
error_common=' is not set when it should be. You can activate it in the Core Netfilter Configuration'
if kernel_is lt 2 6 20 ; then
CONFIG_CHECK="~IP_NF_CONNTRACK_NETLINK"
ERROR_IP_NF_CONNTRACK_NETLINK="CONFIG_IP_NF_CONNTRACK_NETLINK:\t${error_common}"
else
CONFIG_CHECK="~NF_CT_NETLINK"
ERROR_NF_CT_NETLINK="CONFIG_NF_CT_NETLINK:\t${error_common}"
fi
check_extra_config
}
src_configure() {
econf $(use_enable static-libs static)
}
src_install() {
default
prune_libtool_files
}