blob: 915c6f48d2b4e47d64b963820b8c8bd177b82827 [file] [log] [blame]
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
inherit eutils versionator
MY_PV=${PV%.?}-${PV##*.}
MY_PV=${PV}
MY_P=${PN}2-${MY_PV}
DESCRIPTION="library that hides the complexity of using the SIP protocol for multimedia session establishement"
HOMEPAGE="http://savannah.nongnu.org/projects/exosip/"
SRC_URI="http://download.savannah.nongnu.org/releases/exosip/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos ~x86-macos"
SLOT="0/$(get_version_component_range 1-2)"
LICENSE="GPL-2"
IUSE="+srv ssl"
DEPEND=">=net-libs/libosip-4.0.0:=
ssl? ( dev-libs/openssl )"
RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
src_configure() {
econf \
--enable-mt \
$(use_enable ssl openssl) \
$(use_enable srv srvrec)
}
src_install() {
emake DESTDIR="${D}" install
dodoc AUTHORS ChangeLog NEWS README
}