blob: 51c93c5f4f773be4eb201ffe4897a0937d8e334f [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
MY_P=${P/_/-}
DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
HOMEPAGE="http://camaya.net/gloox"
SRC_URI="http://camaya.net/download/${MY_P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="alpha amd64 ~arm ia64 ppc ~ppc64 sparc x86"
IUSE="debug gnutls idn ssl zlib"
DEPEND="idn? ( net-dns/libidn )
gnutls? ( net-libs/gnutls )
ssl? ( dev-libs/openssl )
zlib? ( sys-libs/zlib )"
RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
src_configure() {
econf \
$(use_enable debug debug) \
$(use_with idn libidn) \
$(use_with gnutls gnutls) \
$(use_with ssl openssl) \
$(use_with zlib zlib)
}
src_install() {
emake DESTDIR="${D}" install
}