blob: a5f427b687caad1df616ec046844bf5279fbe3cf [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
USE_RUBY="ruby19 ruby20 ruby21 ruby22"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="README.markdown"
inherit multilib ruby-fakegem
DESCRIPTION="A Ruby library that does autolinking"
HOMEPAGE="https://github.com/vmg/rinku"
LICENSE="ISC"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
each_ruby_configure() {
${RUBY} -Cext/${PN} extconf.rb || die
}
each_ruby_compile() {
emake V=1 -Cext/${PN}
cp ext/${PN}/${PN}$(get_modname) lib/ || die
}
each_ruby_test() {
${RUBY} -Ilib test/autolink_test.rb || die
}