blob: 082aac1ee3a49cdd9335b1f4c9bca98f8796911d [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
# jython depends on java-config, so don't add it or things will break
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit distutils-r1
DESCRIPTION="Java environment configuration query tool"
HOMEPAGE="https://www.gentoo.org/proj/en/java/"
SRC_URI="https://dev.gentoo.org/~sera/distfiles/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="2"
KEYWORDS="amd64 ~arm ppc64 x86 ~amd64-fbsd ~x86-fbsd"
IUSE=""
# baselayout-java is added as a dep till it can be added to eclass.
RDEPEND="
>=dev-java/java-config-wrapper-0.15
sys-apps/baselayout-java
sys-apps/portage"
python_test() {
esetup.py test
}