blob: 516b066f7f80035f30bddda97c2b0b87a6594745 [file] [log] [blame]
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit xfconf
DESCRIPTION="Unified widgets and session management libraries for the Xfce desktop environment"
HOMEPAGE="http://www.xfce.org/projects/libxfce4"
SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
IUSE="debug glade startup-notification"
RDEPEND=">=dev-libs/glib-2.24
>=x11-libs/gtk+-2.20:2
x11-libs/libX11
x11-libs/libICE
x11-libs/libSM
>=xfce-base/libxfce4util-4.10
>=xfce-base/xfconf-4.10
glade? ( dev-util/glade:3 )
startup-notification? ( x11-libs/startup-notification )
!xfce-base/xfce-utils"
DEPEND="${RDEPEND}
dev-lang/perl
dev-util/intltool
virtual/pkgconfig
sys-devel/gettext"
pkg_setup() {
XFCONF=(
$(use_enable startup-notification)
$(use_enable glade gladeui)
$(xfconf_use_debug)
--with-vendor-info=Gentoo
--with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
)
[[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
}