blob: 2388d35d47aa473eda968025c11179d856c62b21 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit eutils multilib toolchain-funcs
DESCRIPTION="a dockapp and gkrellm plug-in combining timecop's bubblemon and wmfishtime"
HOMEPAGE="http://www.jnrowe.ukfsn.org/projects/bfm.html"
SRC_URI="http://www.jnrowe.ukfsn.org/files/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc ~sparc x86 ~amd64-linux ~x86-linux"
IUSE="gkrellm"
RDEPEND="x11-libs/gtk+:2
x11-libs/libX11
x11-libs/libXext"
DEPEND="${RDEPEND}
virtual/pkgconfig
gkrellm? ( >=app-admin/gkrellm-2 )"
src_prepare() {
epatch "${FILESDIR}"/${P}-makefile.patch
}
src_compile() {
emake CC="$(tc-getCC)" GENTOO_LDFLAGS="${LDFLAGS}"
use gkrellm && emake gkrellm CC="$(tc-getCC)"
}
src_install() {
dobin bubblefishymon
doman doc/*.1
dodoc ChangeLog* README* doc/*.sample
if use gkrellm; then
insinto /usr/$(get_libdir)/gkrellm2/plugins
doins gkrellm-bfm.so
fi
}