blob: 9b6a4fea86457720bc11c244a4d94939333ed37f [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
USE_RUBY="ruby20 ruby21"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README.md History.markdown"
inherit ruby-fakegem
DESCRIPTION="Rebuild your Jekyll site when a file changes with the --watch switch"
HOMEPAGE="https://github.com/jekyll/jekyll-watch"
SRC_URI="https://github.com/jekyll/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
ruby_add_rdepend ">=dev-ruby/listen-3.0"
ruby_add_bdepend "test? ( >=www-apps/jekyll-2 )"
all_ruby_prepare() {
rm Rakefile || die
}