blob: 69affa67701b4734b090be3524ea6b2f057e3b5c [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
inherit apache-module
DESCRIPTION="An Apache authentication module using Kerberos"
HOMEPAGE="http://modauthkerb.sourceforge.net/"
SRC_URI="mirror://sourceforge/modauthkerb/${P}.tar.gz"
LICENSE="BSD openafs-krb5-a HPND"
SLOT="0"
KEYWORDS="~amd64 x86"
IUSE=""
DEPEND="virtual/krb5"
RDEPEND="${DEPEND}"
APACHE2_MOD_CONF="11_${PN}"
APACHE2_MOD_DEFINE="AUTH_KERB"
DOCFILES="INSTALL README"
need_apache2_2
src_compile() {
CFLAGS="" APXS="${APXS}" econf --with-krb5=/usr --without-krb4 || die "econf failed"
emake || die "emake failed"
}