blob: 0e3e576326315c675cbb40e31d6f7e573b482b5f [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
inherit toolchain-funcs eutils
DESCRIPTION="tool for easily renaming files"
HOMEPAGE="http://rename.sourceforge.net/"
SRC_URI="http://${PN}/sourceforge.net/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE=""
src_prepare() {
sed -i \
-e '/^CFLAGS/s:-O3:@CFLAGS@:' \
-e '/strip /s:.*::' \
Makefile.in || die
epatch "${FILESDIR}"/${P}-rename.patch
epatch "${FILESDIR}"/${P}-build.patch
epatch "${FILESDIR}"/${P}-gcc44.patch
tc-export CC
}
src_install() {
newbin rename renamexm
newman rename.1 renamexm.1
dodoc README ChangeLog
}
pkg_postinst() {
ewarn "This has been renamed to 'renamexm' to avoid"
ewarn "a naming conflict with sys-apps/util-linux."
}